RU Game won't start.. Help Please

  • Update: The issue has been fixed, please update your patcher to v5. There are currently issues regarding the English Patch for Lost Ark RU. Please read the forum post about the issue here.

PortaPaletes

New member
Nov 19, 2019
1
0
1
Portugal
**Hello there!**
*So... I've watched every tutorial and tried almost every solution available online.
*Here's the problem:
The game starts to load and the splash art pops up. Shortly after it disappears and so does the game process in my task manager. After that, nothing happens.

*Here's what I've already tried:
Restart Computer: Lost count.. Several times
Verify and fix files: 5 times
Reinstall Everything
2 fresh installs, in different disks
Run everything on Admin (VPN, GameCenter and LostArk)
4 Different VPN'S
Disable RTSS (RiverTurner Statatics Select), Disable every app not related to the game (RazorSynapsne, RoccatApp, SteelSeriesApp, Etc..)
Disable Windows Firewall and Windows Defender (Add everything to the exceptions list) -- I don't have an Antivirus

After every attempt I restarted the pc and still nothing happens after the splash art..

Can anyone help me?

Thanks in advance..
 

easly1989

New member
Nov 13, 2019
6
2
3
30
Italy
github.com
The problem you are having seems to be related just to that;
When you click play in the GameCenter do you still see the big red square telling you that you can't play in your region?
In that case, what kind of VPN are you using?
I would suggest you Mudfish or Exitlag (expensive, but easy to buy and setup), or if you just want to try but don't want to spend money on it, go for UrbanVPN (very bad ping, but should at least let you get in the game)

I use mudfish, and what you need to do (and this applies to any kind of VPN except Exitlag probably), is to select a Russian Node to connect to.
You can check that your VPN is working going on any site like whatsmyip or similar, so that you can see where your are located (and it should point to Russia obviously).